Back to overview
Downtime
AFHArchive is unavailable
Aug 7, 2025 at 2:47am UTC
Affected services
AFHArchive
Resolved
Aug 7, 2025 at 5:23am UTC
AFHArchive is back
Affected services
Updated
Aug 7, 2025 at 5:17am UTC
Power is back and AFHArchive will be back soon
Affected services
Created
Aug 7, 2025 at 2:47am UTC
The power is currently out at the AFHArchive server, estimated restoration time is 5:30pm AWST (GMT+08:00)
Affected services